
EMERING OY 
Solutions by Study 

Version 

2.2

Emering Animator
User Manual



2222 

 

U S E R  M A N U A L  

Emering Animator 

 Emering Oy 
P.O. Box 137 •53101 Lappeenranta •Finland 

e-mail : info@emering.fi 
www.emering.fi 

 



3333 

Table of Contents 
Introduction 4 
Installation 5 

System Requirements 5 
Setup Procedure 5 
Un-installation Procedure 6 

Quick Start 8 
Run Emering Animator 8 
Load Your Model 8 
Load Your Data 9 
Quit Emering Animator 9 

Commands & Buttons 10 
Menus 10 
Mouse 11 
Buttons & Sliders 11 

File Formats 13 
Model Files 13 
Data Files 15 

Version Info & Bug Fixes 16 
Version 2.2 16 
Version 2.1 16 
Version 2.0 16 

 



4444 

Introduction 
What it is and what it can? 

mering Animator software allows to animate data related to 3D structural models. These 
data can be displacements, operating deflection shapes, vibration mode shapes and other. 

Data for animations can be obtained by measuring structures, or by modeling structural behavior 
using finite elements. Emering Animator uses OpenGL graphic library. Version 2.1 of the 
Emering Animator is able to display 1D point elements and 2D line and roll elements. 
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Installation 
What you need? How to install? How to uninstall? 

System Requirements 
ystem requirements for Emering Animator are : 

•  Windows 98, NT, ME, 2000 or XP.  
•  About 7Mb of free space on the hard disk. 
•  A pointing device (mouse). 

Setup Procedure 
here are 2 ways to install Emering Animator : either by using  a special setup program which 
automatically installs the software on your computer (automatic setup), or via manual 

installation by copying all necessary files into chosen directory (manual setup).  

1. Automatic setup is easier, but zip-file to be download is a bit larger than for 
manual setup. Installation steps for automatic setup  

1.1 Download file EmeringAnimatorSetup.zip from the downloads 
page at http://www.emering.fi. 

1.2 Extract contents of EmeringAnimatorSetup.zip i.e. setup files, 
to a temporary directory (c:\temp, for example).  Setup files contained in 
zip-archive EmeringAnimatorSetup.zip, are : 
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1.3 Run Setup.exe and follow installation instructions. Setup program 
automatically installs all necessary files and creates program icons. 

1.4 Delete setup files from temporary directory. 

1.5 Run Emering Animator by clicking on Emering Animator icon, created by 
setup software. 

 

2. Manual setup goes according to the 3 steps listed below :  

2.1 Download file EmeringAnimatorFiles.zip from the downloads 
page at http://www.emering.fi. 

2.2 Extract contents of EmeringAnimatorFiles.zip i.e. Emering 
Animator’s program files, to a directory where you wish to install the 
software (c:\Program Files\EmeringAnimator, for example).  Program 
files and a subdirectory , contained in zip-archive 
EmeringAnimatorFiles.zip are shown below. Note that 
subdirectory \Data contains 2 sample files  : Data.dat and 
Model.dat. 

 

2.3 Run Emering Animator by double-clicking on EmerAnim.exe. 
Optionally you can add Desktop shortcuts to the software. 

 

Un-installation Procedure 
epending on how did you install Emering Animator, there are 2 ways to uninstall the 
software : 

1. Automatic un-installation. Use this procedure if you automatically installed 
Emering Animator : 

1.1 Click on Start Menu -> Control Panel -> Add/Remove Programs. 
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1.2 Select Emering Animator and click Remove. Emering Animator will then 
be removed from your computer. 

 

2. Manual un-installation. Use this procedure if you installed Emering Animator 
manually :  

2.1 Delete all files and subdirectories you have created during manual 
installation. Note that Emering Animator does not copy files to Windows 
system directory, neither it adds or changes Windows registry entries. 
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Quick Start 
Basic steps to visualize your 3D model. 

Run Emering Animator 
f you have installed the software (for installation information see previous chapter), then click 
on Emering Animator’s icon, or execute file EmerAnim.exe.  

Two windows will appear : larger window is the Model Window and the smaller window is the 
Legend Window (see figure below). The Model Window displays 3D model of the structure to 
be animated. It also allows to scale and to rotate the model, as well as to change animation speed.  
The Legend Window allows to select between data sets loaded. 

 

 

 

Load Your Model 
hen you first execute Emering Animator, then a demo-model is automatically loaded and 
visualized (demo model can be found in file ..\Data\Model.dat). To load your own model : 

1. Unload current model by choosing the Clear Model command from the File 
menu. Current model and related data disappears. 
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2. Load your model by choosing the Load Model command from the File Menu.  

3. Select model file from the File Open Dialog and click Open. Note that model 
files have a specific format (see chapter File Formats for more information) By 
default a model from file ..\Data\Model.dat is displayed. 

4. Verify that the Show Model menu command in the Options Menu is checked. 
Check it if it is unchecked, otherwise the model will not appear on the screen. 

Now, if file format of your model is correct, then you should see the 3D image of the  model 
chosen. You can rotate and scale the model by holding down the left and the right mouse 
buttons, correspondingly. See chapter Commands and Buttons for a complete reference about 
how to manipulate the model. 

Load Your Data 
hen you first execute Emering Animator, then a demo-demo data is automatically 
loaded with the demo model (demo data can be found from file 

..\Data\Data.dat). To load data other than the demo-data : 

1. Unload current data by choosing the Clear Data command from the File menu. 
Data, related to a current model disappears. 

2. Load your data by choosing the Load Data command from the File Menu.  

3. Select data file from the File Open Dialog and click Open. Note that data files, 
as model files, have a specific format (see chapter File Formats for details) By 
default data from file ..\Data\Data.dat is displayed. 

If data format loaded is correct, then you should see a list of data sets appear in the Legend 
Window. Select a data set to be animated by clicking on appropriate item in the Data Sets List.  

Animate data by clicking the Animate Button . You can rotate and scale the model 
during animation. To stop the animation click on the Animate Button again. 

To increase or to decrease the scale of the data, move the Scale Slider right or 
left.  

To  increase or decrease the speed of animation, move the Speed Slider. 

Quit Emering Animator 
o exit Emering Animator, choose the Exit Command from the File Menu, or click the Close 

Button  of the Model Window.  
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Commands & Buttons  
All about menu, mouse and button commands. 

Menus 
File 

Load Model… Loads Emering Animator’s model files. Model files are 
ASCII text files having a specific format (see chapter File 
Formats). This function is disabled in demo version 

Load Data… Loads Emering Animator’s data files. Data files are ASCII 
text files having a specific format (see chapter File Formats). 
This function is disabled in demo version 

Clear Model Unloads current model and data related to it. This function 
is disabled in demo version 

Clear Data Unloads data related to the current model. This function is 
disabled in demo version 

Save As 
Bitmap… 

Converts current view of the model into Windows bitmap 
format and saves the picture into a file.  

Exit Quits the application 

 

Edit 

Copy Copies image on the clipboard. Shortcut key for the Copy 
command is Ctrl+C. 

 

Options 

Colors !!!! Prompts the Color Setup Dialog. Choose a color and click 
OK to change color of an item. Items are listed below. 
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Font… Font color of the Legend Window 

Background… Background color of the Model and Legend Windows 

Elements… Color of elements whose color ID in the model file is -1 

Nodes… Color of all nodes 

Node Shapes !!!! Allows to change shape of nodes. Possible shapes are listed 
below 

Sphere Nodes are drawn as spheres 

Cube Nodes are drawn as cubes  

Show Model Check or uncheck this menu to display or hide the model 

Show Legend Check or uncheck this menu to display or hide the Legend 
Window 

Save options on 
Exit 

Check this menu if you wish that all current settings are 
saved after the application quits. If unchecked, then settings 
are not stored. Note that all settings are stored in text file 
EmerAnim.ini. You can change settings also by editing 
the ini-file. 

 

Help 

About… Shows the About Window. 

 

Mouse 
Left MB  To rotate the viewport (MB=Mouse Button) 

Right MB  

Ctrl+Left MB To scale (to zoom) the viewport 

Middle MB 

Shift+Left MB To pan the viewport 

 

Buttons & Sliders 
View 

 Displays Y-Z plane 
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Displays X-Z plane 

  
Displays X-Y plane 

  
Displays default 3D view 

  
Scales whole model into the window 

 

Animation 

 

 

The Animate Button switches animation mode of the 
model On/Off 

  
Displays one animation step backwards (the Animate 
Button must be switched Off) 

  
Displays one animation step forward (the Animate Button 
must be switched Off) 

 
 

Changes the animation speed. Note that the actual speed 
depends on capabilities of your computer. 

 

Scaling the Data 

  Absolute scaling – scale factor is computed using 
magnitudes of all loaded data sets. This scaling mode 
allows to compare magnitudes of different data sets 

  Relative scaling – scale factor is computed using magnitudes 
of a selected data set. This scaling mode allows to compare 
magnitudes of different data sets 

  Summed display – selected data sets are summed and 
displayed as one data set. Note that to select multiple data 
sets, hold down the Ctrl key when selecting data sets by a 
mouse. 

 
 

Changes magnitude of the scale factor.  
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File Formats 
How to create model? How to organize related data? 

n order to enable Emering Animator to load and visualize 3D models and related data, 
the model and data must be ordered according to a specific format. Data describing a 

model is given in ASCII text files called Model Files. Data, describing the model behavior, is 
given in ASCII text files called Data Files. 

Model Files 
Model properties such as node coordinates and element topography have to be written in 
Model File according to a specific format : The Model File contains 3 sections : options, 
nodes and element sections : 

[Options] 
NodeRadius=rnode 
ElementRadius=relement 
 
[Nodes] 
NodeID CoordinateX CoordinateY CoordinateZ 
. . . . . 
 
[Elements] 
CountOfElements 
ElementID Element type-dependent data (see table below) 
. . . . . 
 

Element Type Data/Description 

Line elements 1 relement ColorID 2 IDnode1 IDnode2 
 1 type identifier for line elements 

relement  element radius. If relement =0 , then element is drawn 
as a rectangular bars, otherwise the element is 
drawn as a cylinder. 

ColorID  element color 
IDnode1 identifier of the first node 
IDnode2 identifier of the second node 
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Roll elements 2 rroll raxle 2Laxle/Lroll ColorID 2 IDnode1 IDnode2 
 2 type identifier for roll elements 

rroll  roll radius 
raxle  axle radius 
2Laxle/Lroll  ratio of 2 axle lengths to the roll length. If this 

ratio is 0 then element is drawn as a cylinder. 
Maximum value of the ratio is 1.0. 

ColorID  element color 
IDnode1 identifier of the first node 
IDnode2 identifier of the second node 

Planar elements 3 ColorID NodeCount IDnode1 IDnode2 . . . IDnodeN 
 3 type identifier for planar elements 

ColorID  element color 
IDnode1 identifier of the first node 
IDnode2 identifier of the second node 
IDnodeN identifier of the last node 

Node elements 15 relement ColorID 1 IDnode 
 15 type identifier for node elements 

relement  element radius 
ColorID  element color 
IDnodeN identifier of the node 

 
For example : 

[Nodes] 
1 0.00 0.00 0.00 
2 0.00 3.20 0.00 
3 1.40 3.20 0.00 
4 1.40 0.00 0.00 
5 1.40 2.70 0.00 
6 5.90 2.70 0.00 
 [Elements] 
5 
1 1 0 -1 2 1 2 
2 1 0 -1 2 3 4 
3 1 0 -1 2 4 5 
4 15 0 255 1 6 
5 1 0.52 16500 2 2 3 
 

Elements 1, 2 3 and 5 in example, are line elements of type 1, having 2 nodes each, and element 4 
is a point element of type 15, having one node. Note that section names ([Nodes] and 
[Elements]), are case sensitive i.e. if section is named for example [eleMeNts], then elements of 
the model will not be loaded. If ElementColor of an element is set to -1 then software displays this 
element by a default element color. If ElementRadius is greater than 0 (element 5 in our example), 
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then elements are drawn as rolls, otherwise elements are drawn as rectangular tubes having a 
diameter equal to a variable ElementRadius, defined  in section [Options]. 

Data Files 
Data File contains arbitrary count of sections, where each section represents a data set. 
Section names i.e. the data set names which appear in the Legend Window, should be 
placed inside parentheses (for example section  [F=6.75Hz] appears as a list item F=6.75Hz 
in the Legend Window). Data in every section should be formatted as follows : 

[Section Name for Complex Data] 
NodeID MagnitudeX MagnitudeY MagnitudeZ PhaseAngleX PhaseAngleY PhaseAngleZ 
. . . . . 
 

For example : 

1 0.00000E+00 0.00000E+00 0.00000E+00 0.00000E+00 0.00000E+00 0.00000E+00 

2 2.10000E-02 0.00000E+00 -6.07000E-01 0.00000E+00 0.00000E+00 0.00000E+00 

3 2.00000E-02 -1.00000E-03 6.98000E-01 0.00000E+00 0.00000E+00 0.00000E+00 

4 0.00000E+00 0.00000E+00 0.00000E+00 0.00000E+00 0.00000E+00 0.00000E+00 

5 1.40000E-02 -1.00000E-03 6.34000E-01 0.00000E+00 0.00000E+00 0.00000E+00 

6 9.00000E-03 0.00000E+00 -1.40000E-02 0.00000E+00 0.00000E+00 0.00000E+00 

NodeIDs should correspond to the NodeIDs in the model file. If data for particular node is 
missing, then it is considered to be 0 (i.e. representing non-moving node). Order of nodes 
can be arbitrary. Phase angles of complex data should be in radians. 
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Version Info & Bug Fixes 
How it grows? What have been the problems? 

Version 2.2 
02.11.2003 

•  2 new element types (rolls and planar elements) added. 

•  Changes in format of the model file : section [Options] added. 

•  Copy command added to the Edit Menu. 

Version 2.1 
06.10.2003 

•  Old Windows98-style buttons have been replaced by “smooth” buttons. 

•  Tested under Windows 98 and XP. 

•  New User Manual. 

•   

Version 2.0 
29.09.2003 

•  Smooth rendering of the model (with lighting). 

•  Line elements with defined radius are drawn as rolls. 

•  Tested under Windows XP. 

•  Hangs up under Windows 98. This bug is fixed in Version 2.1 
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